ntcdcrypto 0.2.0 copy "ntcdcrypto: ^0.2.0" to clipboard
ntcdcrypto: ^0.2.0 copied to clipboard

ntc_dcrypto is module dart cryptography. Includes utility classes for encryption in the Dart programming.

2
likes
150/ 160
pub points
68%
popularity

We analyzed this package 40 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 28 API elements (82.1 %) have documentation comments.

Some symbols that are missing documentation: ntcdcrypto.SSS, ntcdcrypto.SSS.SSS, ntcdcrypto.SSS.maxInt16, ntcdcrypto.SSS.prime, ntcdcrypto.SSS.rand.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: An uninitialized variable should have an explicit type annotation.

lib/ntcdcrypto.dart:425:9

    ╷
425 │     var points;
    │         ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ntcdcrypto.dart

lib/ntcdcrypto.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
hex ^0.2.0 0.2.0 0.2.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
150
pub points
68%
popularity

Publisher

unverified uploader

ntc_dcrypto is module dart cryptography. Includes utility classes for encryption in the Dart programming.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, hex

More

Packages that depend on ntcdcrypto