nine_patcher 1.0.1 copy "nine_patcher: ^1.0.1" to clipboard
nine_patcher: ^1.0.1 copied to clipboard

A command line tool to creates nine-patch JSON metadata files.

0
likes
140/ 160
pub points
49%
popularity

We analyzed this package 23 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 8 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: nine_patcher, nine_patcher.NinePatchImage.fromFile, nine_patcher.NinePatchImage.NinePatchImage.fromImage, nine_patcher.NinePatchImage.image, nine_patcher.NinePatchImage.metadata.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.2 2.5.0 2.5.0
image ^4.0.17 4.2.0 4.2.0
json_annotation ^4.8.1 4.9.0 4.9.0
nine_patch_common ^1.0.0 1.0.0 1.0.0
path ^1.8.3 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
collection - 1.19.0 1.19.0
crypto - 3.0.3 3.0.3
meta - 1.15.0 1.15.0
petitparser - 6.0.2 6.0.2
typed_data - 1.3.2 1.3.2
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

0
likes
140
pub points
49%
popularity

Publisher

verified publisherbramp.net

A command line tool to creates nine-patch JSON metadata files.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

args, image, json_annotation, nine_patch_common, path

More

Packages that depend on nine_patcher