ngd_datatable 0.1.9+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 71

This plugin is made to display a data table on Angular Dart platform. Currently it support a simple data table with or without server processing.

Usage #

A simple usage example:

import 'package:ngd_datatable/ngd_datatable.dart';

for more information about usage and demo please follow this link.

0.1.9+2 #

  • Bug fixing flex and column width

0.1.9+1 #

  • Bug fixing flex and column width

0.1.9 #

  • Change table style to flex
  • Adding flexWidth to set column width relatively

0.1.8 #

  • Adding Alignment and column width

0.1.7 #

  • Adding support for dynamically add a component into the table

0.1.6 #

  • Bug fixing loading bar
  • Update documentation and example

0.1.5 #

  • Bug fixing server side data

0.1.4 #

  • Adding support for filtering by column

0.1.3 #

  • Adding support for html inside column formatter

0.1.2 #

  • Fixing pagination bug
  • Adding support for non JSON data type

0.1.1 #

  • Update dart format

0.1.0 #

  • Initial version

example/README.md

Usage #

Run this example with webdev serve

for more information about usage and demo please follow this link.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ngd_datatable: ^0.1.9+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ngd_datatable/ngd_datatable.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because of the import of dart:html via the import chain package:ngd_datatable/ngd_datatable.dartpackage:ngd_datatable/src/datatable.dartpackage:ngd_datatable/src/components/wrapper/wrapper_component.dartpackage:angular/angular.dartpackage:angular/src/platform/browser/tools/tools.dartpackage:angular/src/platform/browser/tools/common_tools.dartpackage:angular/src/core/linker/component_factory.dartpackage:angular/src/core/linker/view_ref.dartdart:html

Package not compatible with runtime flutter-native on ios

Because of the import of dart:html via the import chain package:ngd_datatable/ngd_datatable.dartpackage:ngd_datatable/src/datatable.dartpackage:ngd_datatable/src/components/wrapper/wrapper_component.dartpackage:angular/angular.dartpackage:angular/src/platform/browser/tools/tools.dartpackage:angular/src/platform/browser/tools/common_tools.dartpackage:angular/src/core/linker/component_factory.dartpackage:angular/src/core/linker/view_ref.dartdart:html

Package not compatible with runtime flutter-native on linux

Because of the import of dart:html via the import chain package:ngd_datatable/ngd_datatable.dartpackage:ngd_datatable/src/datatable.dartpackage:ngd_datatable/src/components/wrapper/wrapper_component.dartpackage:angular/angular.dartpackage:angular/src/platform/browser/tools/tools.dartpackage:angular/src/platform/browser/tools/common_tools.dartpackage:angular/src/core/linker/component_factory.dartpackage:angular/src/core/linker/view_ref.dartdart:html

Package not compatible with runtime flutter-native on macos

Because of the import of dart:html via the import chain package:ngd_datatable/ngd_datatable.dartpackage:ngd_datatable/src/datatable.dartpackage:ngd_datatable/src/components/wrapper/wrapper_component.dartpackage:angular/angular.dartpackage:angular/src/platform/browser/tools/tools.dartpackage:angular/src/platform/browser/tools/common_tools.dartpackage:angular/src/core/linker/component_factory.dartpackage:angular/src/core/linker/view_ref.dartdart:html

Package not compatible with runtime flutter-native on windows

Because of the import of dart:html via the import chain package:ngd_datatable/ngd_datatable.dartpackage:ngd_datatable/src/datatable.dartpackage:ngd_datatable/src/components/wrapper/wrapper_component.dartpackage:angular/angular.dartpackage:angular/src/platform/browser/tools/tools.dartpackage:angular/src/platform/browser/tools/common_tools.dartpackage:angular/src/core/linker/component_factory.dartpackage:angular/src/core/linker/view_ref.dartdart:html

Package not compatible with runtime native-aot

Because of the import of dart:html via the import chain package:ngd_datatable/ngd_datatable.dartpackage:ngd_datatable/src/datatable.dartpackage:ngd_datatable/src/components/wrapper/wrapper_component.dartpackage:angular/angular.dartpackage:angular/src/platform/browser/tools/tools.dartpackage:angular/src/platform/browser/tools/common_tools.dartpackage:angular/src/core/linker/component_factory.dartpackage:angular/src/core/linker/view_ref.dartdart:html

Package not compatible with runtime native-jit

Because of the import of dart:html via the import chain package:ngd_datatable/ngd_datatable.dartpackage:ngd_datatable/src/datatable.dartpackage:ngd_datatable/src/components/wrapper/wrapper_component.dartpackage:angular/angular.dartpackage:angular/src/platform/browser/tools/tools.dartpackage:angular/src/platform/browser/tools/common_tools.dartpackage:angular/src/core/linker/component_factory.dartpackage:angular/src/core/linker/view_ref.dartdart:html

Health issues and suggestions

Document public APIs. (-0.20 points)

71 out of 73 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/classes/column.dart.

Run dartfmt to format lib/src/classes/column.dart.

Format lib/src/components/body/body_component.dart.

Run dartfmt to format lib/src/components/body/body_component.dart.

Format lib/src/components/cell/cell_component.dart.

Run dartfmt to format lib/src/components/cell/cell_component.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/components/filterCell/filter_cell_component.dart (Run dartfmt to format lib/src/components/filterCell/filter_cell_component.dart.)
  • lib/src/components/footer/footer_component.dart (Run dartfmt to format lib/src/components/footer/footer_component.dart.)
  • lib/src/components/header/header_component.dart (Run dartfmt to format lib/src/components/header/header_component.dart.)
  • lib/src/components/headerCell/header_cell_component.dart (Run dartfmt to format lib/src/components/headerCell/header_cell_component.dart.)
  • lib/src/datatable.dart (Run dartfmt to format lib/src/datatable.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
angular ^5.3.0 5.3.1 6.0.0-alpha+1
angular_components ^0.13.0 0.13.0+1 0.14.0-alpha+1
angular_router ^2.0.0-alpha+19 2.0.0-alpha+22 2.0.0-alpha+24
intl ^0.15.0 0.15.8 0.16.1
Transitive dependencies
analyzer 0.35.4 0.39.11
angular_ast 0.5.9 0.5.11
angular_compiler 0.4.3 0.4.5
angular_forms 2.1.2 2.1.4
args 1.6.0
async 2.4.1
build 1.3.0
build_config 0.4.2
built_collection 4.3.2
built_value 7.1.0
charcode 1.1.3
checked_yaml 1.0.2
cli_repl 0.2.0+1
code_builder 3.3.0
collection 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.14.6+1 0.16.1
dart_internal 0.1.9
dart_style 1.2.4 1.3.6
fixnum 0.10.11
front_end 0.1.14 0.1.29
glob 1.2.0
http 0.12.1
http_parser 3.1.4
js 0.6.2
json_annotation 3.0.1
kernel 0.3.14 0.3.29
logging 0.11.4
matcher 0.12.8
meta 1.1.8
node_interop 1.1.1
node_io 1.1.1
observable 0.22.2
package_config 1.9.3
package_resolver 1.0.10
path 1.7.0
protobuf 0.13.16+1 1.0.1
pub_semver 1.4.4
pubspec_parse 0.1.5
quiver 2.1.3
sass 1.26.9
sass_builder 2.1.3
source_gen 0.9.4+4 0.9.5
source_maps 0.10.9
source_span 1.7.0
stack_trace 1.9.5
stream_transform 1.2.0
string_scanner 1.0.5
term_glyph 1.1.0
tuple 1.0.3
typed_data 1.2.0
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
angular_test ^2.3.0
build_runner ^1.6.0
build_test ^0.10.8
build_web_compilers ^2.3.0
pedantic ^1.8.0 1.9.0 1.9.1
test ^1.6.0