ngast 2.1.4 copy "ngast: ^2.1.4" to clipboard
ngast: ^2.1.4 copied to clipboard

Parser and utilities for AngularDart templates

2
likes
130/ 160
pub points
73%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

382 out of 556 API elements (68.7 %) have documentation comments.

Some symbols that are missing documentation: angular_ast, ngast, ngast.ContainerAst.ContainerAst.from, ngast.ContainerAst.ContainerAst.parsed, ngast.DesugarVisitor.exceptionHandler.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 28 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/ast/attribute.dart:44:17

   ╷
44 │   bool operator ==(Object? other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ast/attribute.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/ast/close_element.dart:32:17

   ╷
32 │   bool operator ==(Object? other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ast/close_element.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
charcode ^1.1.0 1.3.1 1.3.1
collection ^1.14.5 1.19.0 1.19.0
meta ^1.1.4 1.15.0 1.15.0
source_span ^1.4.0 1.10.0 1.10.0
string_scanner ^1.0.1 1.2.0 1.2.0
Transitive dependencies
Package Constraint Compatible Latest
path - 1.9.0 1.9.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.