ng_bootstrap 1.2.0 icon indicating copy to clipboard operation
ng_bootstrap: ^1.2.0 copied to clipboard

Platformweb

Angular 2 and Bootstrap 4

3
likes
70/ 130
pub points
75%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 588 out of 906 API elements (64.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:ng_bootstrap/ng_bootstrap.dart that imports:
  • package:ng_bootstrap/core/position.dart that imports:
  • dart:html
Package not compatible with platform iOS

Because:

  • package:ng_bootstrap/ng_bootstrap.dart that imports:
  • package:ng_bootstrap/core/position.dart that imports:
  • dart:html
Package not compatible with platform Windows

Because:

  • package:ng_bootstrap/ng_bootstrap.dart that imports:
  • package:ng_bootstrap/core/position.dart that imports:
  • dart:html
Package not compatible with platform Linux

Because:

  • package:ng_bootstrap/ng_bootstrap.dart that imports:
  • package:ng_bootstrap/core/position.dart that imports:
  • dart:html
Package not compatible with platform macOS

Because:

  • package:ng_bootstrap/ng_bootstrap.dart that imports:
  • package:ng_bootstrap/core/position.dart that imports:
  • dart:html
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 58 issues. Showing the first 2:

INFO: Prefer typing uninitialized variables and fields.

lib/components/button/radio.dart:12:7

   ╷
12 │   var option;
   │       ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/components/button/radio.dart

INFO: Prefer typing uninitialized variables and fields.

lib/components/button/radio.dart:22:7

   ╷
22 │   var _value;
   │       ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/components/button/radio.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^6.0.06.0.17.0.2
angular_forms^3.0.03.0.04.0.1
bootstrap_sass^4.3.14.5.04.5.0
font_awesome^5.10.15.10.15.10.1
intl^0.16.00.16.10.17.0
js_shims^1.0.01.0.01.0.0
stream_transform^1.2.01.2.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.041.0.0
analyzer-0.40.74.2.0
angular_ast-1.0.12.0.1
angular_compiler-1.0.12.0.2
args-1.6.02.3.1
async-2.9.02.9.0
build-1.6.22.3.0
build_config-0.4.71.0.0
built_collection-5.1.15.1.1
built_value-8.3.38.3.3
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.5
code_builder-3.7.04.1.0
collection-1.16.01.16.0
convert-2.1.13.0.2
crypto-2.1.53.0.2
csslib-0.16.20.17.2
dart_style-1.3.102.2.3
file-5.2.16.1.2
fixnum-1.0.11.0.1
glob-1.2.02.1.0
js-0.6.40.6.4
json_annotation-4.5.04.5.0
logging-0.11.41.0.2
matcher-0.12.120.12.12
meta-1.8.01.8.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.1
pubspec_parse-0.1.81.2.0
source_gen-0.9.10+21.2.2
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-0.9.7+151.0.1
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^6.0.0` on angular does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions angular to update the constraint.

The constraint `^3.0.0` on angular_forms does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions angular_forms to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Dart 2.17.5.