network_connectivity_troubleshoot 0.0.6 copy "network_connectivity_troubleshoot: ^0.0.6" to clipboard
network_connectivity_troubleshoot: ^0.0.6 copied to clipboard

A new Flutter package for network connectivity troubleshoot

2
likes
60/ 160
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 60 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 4 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: network_connectivity_troubleshoot, network_connectivity_troubleshoot.CheckInternetConnectivity, network_connectivity_troubleshoot.CheckInternetConnectivity.CheckInternetConnectivity, network_connectivity_troubleshoot.CheckInternetConnectivity.checkInternetAndProceed.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:network_connectivity_troubleshoot/network_connectivity_troubleshoot.dart that imports:
  • dart:io
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: The getter 'headline6' isn't defined for the type 'TextTheme'.

lib/network_connectivity_troubleshoot.dart:126:48

    ╷
126 │             style: Theme.of(context).textTheme.headline6,
    │                                                ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/network_connectivity_troubleshoot.dart

ERROR: The named parameter 'primary' isn't defined.

lib/network_connectivity_troubleshoot.dart:162:15

    ╷
162 │               primary: buttonBackgroundColor,
    │               ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/network_connectivity_troubleshoot.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • UNDEFINED_GETTER - lib/network_connectivity_troubleshoot.dart:126:48 - The getter 'headline6' isn't defined for the type 'TextTheme'.
  • UNDEFINED_NAMED_PARAMETER - lib/network_connectivity_troubleshoot.dart:162:15 - The named parameter 'primary' isn't defined.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
60
pub points
0%
popularity

Publisher

unverified uploader

A new Flutter package for network connectivity troubleshoot

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on network_connectivity_troubleshoot