nepali_date_picker 4.1.0

Flutter Android iOS web

Material and Cupertino Style Date Picker and Calendar with Bikram Sambat(Nepali) Calendar Support. Supports Android, iOS and Fuchsia. Available in Nepali and English Languages.

14
likes
95 / 110
pub points
83 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 95 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:4:1

  ╷
4 │ <a href="http://sarbagya.me/nepali_date_picker"><img src="https://img.shields.io/badge/Demo-WEB-blueviolet.svg" alt="Demo" /></a>
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 38 out of 39 API elements (97.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'WhitelistingTextInputFormatter' is deprecated and shouldn't be used. Use FilteringTextInputFormatter.allow instead. This feature was deprecated after v1.20.0-1.0.pre..

lib/src/material/input_date_picker.dart:265:7

    ╷
265 │       WhitelistingTextInputFormatter(RegExp(r'[\d\/\.,-\s]+'));
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/material/input_date_picker.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
nepali_utils>=2.2.1 <3.0.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

14
likes
95
pub points
83%
popularity

Publisher

sarbagyastha.com.np

Material and Cupertino Style Date Picker and Calendar with Bikram Sambat(Nepali) Calendar Support. Supports Android, iOS and Fuchsia. Available in Nepali and English Languages.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, nepali_utils

More

Packages that depend on nepali_date_picker