navigine_api 0.2.1+5

  • Readme
  • Changelog
  • Example
  • Installing
  • 71

navigine_api #

A new flutter plugin project.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.2.1+5 #

  • Improved example app

0.2.1+4 #

  • Fixed delete beacon response check

0.2.1+3 #

  • Added Fix for the save location api call

0.2.1 #

  • Added fix to sub location add call, changed base64 converter

0.2.0 #

  • Added fix to the changed API calls.

0.1.1+3 #

  • Get location response fix.

0.1.1+2 #

  • Typo fixed.

0.1.1+1 #

  • Error management quick fix.

0.1.1 #

  • Fixed locationId to id for fetching location detail.

0.1.0 #

  • Returns version number once map is updated

0.0.3 #

  • Changed the null to 0 using ??

0.0.2 #

  • Save map feature added.

0.0.1 #

  • TODO: Initial release.

example/README.md

navigine_api_example #

Demonstrates how to use the navigine_api plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  navigine_api: ^0.2.1+5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:navigine_api/navigine_api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
59
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-0.72 points)

106 out of 107 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/navigine_api.dart. (-0.50 points)

Analysis of lib/navigine_api.dart reported 1 hint:

line 9 col 8: Unused import: 'package:http_parser/http_parser.dart'.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://bitbucket.org/snowm_c/navigine-flutter-api.git/src was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
http ^0.12.0+2 0.12.0+4
http_parser ^3.1.3 3.1.3
meta ^1.1.6 1.1.8
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
path 1.6.4
pedantic 1.9.0
sky_engine 0.0.99
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test