navigationbaato 0.0.5 icon indicating copy to clipboard operation
navigationbaato: ^0.0.5 copied to clipboard

A new flutter plugin project.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 47 out of 166 API elements (28.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:navigationbaato/navigationbaato.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:navigationbaato/navigationbaato.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:navigationbaato/navigationbaato.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:navigationbaato/navigationbaato.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/embedded/controller.dart:50:21

   ╷
50 │     var pointList = List<Map<String, Object>>();
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/embedded/controller.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/navigationbaato.dart:59:21

   ╷
59 │     var pointList = List<Map<String, Object>>();
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/navigationbaato.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
baato_api^0.0.50.0.51.0.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
dio-3.0.104.0.6
http_parser-3.1.44.0.2
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.0.5 on baato_api does not support the stable version 1.0.0.

Try running dart pub upgrade --major-versions baato_api to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

A new flutter plugin project.

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

baato_api, flutter

More

Packages that depend on navigationbaato