native_widgets 1.3.7+1
native_widgets: ^1.3.7+1 copied to clipboard

A new Flutter package for using Android and iOS natively on each platform.

21
likes
40 / 110
pub points
83 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 1340 issues. Showing the first 2:

ERROR: Classes can only extend other classes.

lib/app/main_app.dart:3:25

  ╷
3 │ class NativeApp extends StatelessWidget {
  │                         ^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/app/main_app.dart

ERROR: Undefined class 'Color'.

lib/app/main_app.dart:5:9

  ╷
5 │   final Color appBackground;
  │         ^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/app/main_app.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because native_widgets depends on flutter_localizations any from sdk which depends on intl 0.17.0-nullsafety.2, intl 0.17.0-nullsafety.2 is required.
So, because native_widgets depends on intl ^0.16.1, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs