native_toolchain_c 0.3.4+1 copy "native_toolchain_c: ^0.3.4+1" to clipboard
native_toolchain_c: ^0.3.4+1 copied to clipboard

A library to invoke the native C compiler installed on the host machine.

5
likes
120/ 140
pub points
91%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: native_toolchain_c,
    • contains a version property, and,
    • does not contain a publish_to property.

pkgs/native_toolchain_c/pubspec.yaml from the repository defines publish_to, thus, we are unable to verify the package is published from here.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

21 out of 28 API elements (75.0 %) have documentation comments.

Some symbols that are missing documentation: native_toolchain_c.Builder, native_toolchain_c.Builder.Builder, native_toolchain_c.Builder.run, native_toolchain_c.CBuilder.CBuilder.executable, native_toolchain_c.CBuilder.CBuilder.library.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:native_toolchain_c/native_toolchain_c.dart that imports:
  • package:native_toolchain_c/src/utils/env_from_bat.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cli_config ^0.1.1 0.1.2 0.1.2
glob ^2.1.1 2.1.2 2.1.2
logging ^1.1.1 1.2.0 1.2.0
meta ^1.9.1 1.12.0 1.12.0
native_assets_cli ^0.4.0 0.4.2 0.4.2
pub_semver ^2.1.3 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
yaml - 3.1.2 3.1.2
yaml_edit - 2.2.0 2.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.4.0-131.0.dev.

Check the analysis log for details.