native_i18n_flutter_plugin 0.1.15
native_i18n_flutter_plugin: ^0.1.15 copied to clipboard

Internationalization Flutter plugin based on Native APIs besides a command line tool to hep you during development phase

0
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 18 out of 73 API elements (24.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:native_i18n_flutter_plugin/native_i18n_flutter_plugin.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

lib/native_i18n_flutter_plugin.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/runner/generators/file_generator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.02.1.0
dcache^0.3.00.3.00.4.0
flutterflutter0.0.00.0.0
logger^0.7.0+20.7.0+21.0.0
path^1.6.01.8.01.8.0
process_run^0.10.20.10.12+30.12.1
sprintf^4.0.24.1.06.0.0
watcher^0.9.7+120.9.7+151.0.0
xml^3.5.03.7.05.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.6.12.6.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
io-1.0.01.0.0
meta-1.3.01.3.0
pedantic-1.11.01.11.0
petitparser-3.1.04.1.0
pub_semver-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.3.0` on dcache does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions dcache to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

0
likes
80
pub points
0%
popularity

Internationalization Flutter plugin based on Native APIs besides a command line tool to hep you during development phase

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

victorescobargonza@gmail.com

License

LICENSE

Dependencies

args, dcache, flutter, logger, path, process_run, sprintf, watcher, xml

More

Packages that depend on native_i18n_flutter_plugin