native_assets_cli 0.4.2 copy "native_assets_cli: ^0.4.2" to clipboard
native_assets_cli: ^0.4.2 copied to clipboard

A library that contains the argument and file formats for implementing a native assets CLI.

6
likes
140/ 140
pub points
99%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

47 out of 129 API elements (36.4 %) have documentation comments.

Some symbols that are missing documentation: native_assets_cli.Architecture.arm, native_assets_cli.Architecture.arm64, native_assets_cli.Architecture.ia32, native_assets_cli.Architecture.riscv32, native_assets_cli.Architecture.riscv64.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:native_assets_cli/native_assets_cli.dart that imports:
  • package:native_assets_cli/src/api/target.dart that imports:
  • package:native_assets_cli/src/model/target.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cli_config ^0.1.1 0.1.2 0.1.2
collection ^1.17.1 1.18.0 1.18.0
crypto ^3.0.3 3.0.3 3.0.3
pub_semver ^2.1.3 2.1.4 2.1.4
yaml ^3.1.1 3.1.2 3.1.2
yaml_edit ^2.1.0 2.2.0 2.2.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.4.2 2.4.2
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.4.0-131.0.dev.

Check the analysis log for details.

6
likes
140
pub points
99%
popularity

Publisher

verified publisherlabs.dart.dev

A library that contains the argument and file formats for implementing a native assets CLI.

Repository (GitHub)
View/report issues
Contributing

Topics

#ffi #interop #native-assets

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

cli_config, collection, crypto, pub_semver, yaml, yaml_edit

More

Packages that depend on native_assets_cli