my_cli 1.0.3 icon indicating copy to clipboard operation
my_cli: ^1.0.3 copied to clipboard

A simple command-line application.

100/ 140
pub points

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid

5/5 points: Provide a valid

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 3 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: my_cli, hello, world.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
50 / 50icon to trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
intl ^0.17.0 0.17.0 0.18.1
js ^0.6.0 0.6.7 0.6.7
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
meta - 1.11.0 1.11.0
path - 1.8.3 1.8.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.21.43, Dart 3.2.1.

Check the analysis log for details.

pub points


verified publisher

A simple command-line application.


API reference


Icon for licenses.BSD-2-Clause (LICENSE)


intl, js


Packages that depend on my_cli