mushroom_dick_sdk 1.0.1 copy "mushroom_dick_sdk: ^1.0.1" to clipboard
mushroom_dick_sdk: ^1.0.1 copied to clipboard

A Dart SDK of Moguding APP.

15/ 140
pub points

We analyzed this package 2 days ago, and awarded it 15 pub points (of a possible 140):

Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid

Links in `` should be secure. 1 link is insecure.

37 │ <p>Please file feature requests and bugs at the <a href="">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Use https URLs instead.

5/5 points: Provide a valid

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.3. Cannot run `dart pub outdated`.


7 │   sdk: '>=2.7.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.3.


7 │   sdk: '>=2.7.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.