multi_window 0.2.0 icon indicating copy to clipboard operation
multi_window: ^0.2.0 copied to clipboard

A package for adding multi window support to Flutter on Desktop.

50
likes
130/ 130
pub points
71%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 22 API elements (68.2 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:multi_window/multi_window.dart that declares support for platforms: Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:multi_window/multi_window.dart that declares support for platforms: Linux, macOS.
Package does not support platform `Windows`.

Because:

  • package:multi_window/multi_window.dart that declares support for platforms: Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:multi_window/multi_window.dart that declares support for platforms: Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Linux`.

Because:

  • package:multi_window/multi_window.dart that imports:
  • package:multi_window_macos/multi_window_macos.dart that declares support for platforms: macOS.
Package does not support platform `macOS`.

Because:

  • package:multi_window/multi_window.dart that imports:
  • package:multi_window_linux/multi_window_linux.dart that declares support for platforms: Linux.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
multi_window_interface^0.2.00.2.00.2.0
multi_window_linux^0.2.00.2.00.2.0
multi_window_macos^0.2.00.2.00.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.