multi_page_form 1.0.4
multi_page_form: ^1.0.4 copied to clipboard

This package helps you to create Multi Page Form in fewer liner of code.

9
likes
90 / 130
pub points
72 %
popularity

We analyzed this package on May 13, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 10 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/multi_page_form.dart:77:25

   ╷
77 │                       : FlatButton(
   │                         ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/multi_page_form.dart

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.25.0-8.1.pre..

lib/multi_page_form.dart:86:25

   ╷
86 │                       ? FlatButton(
   │                         ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/multi_page_form.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev.68.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.

9
likes
90
pub points
72%
popularity

This package helps you to create Multi Page Form in fewer liner of code.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kadarsh.singh@gmail.com

License

LICENSE

Dependencies

flutter

More

Packages that depend on multi_page_form