multi_inappwebview 0.0.4 copy "multi_inappwebview: ^0.0.4" to clipboard
multi_inappwebview: ^0.0.4 copied to clipboard

multiple webview of flutter_inappwebview

0
likes
80/ 160
pub points
0%
popularity

We analyzed this package 12 hours ago, and awarded it 80 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/fast-flutter/multi_inappwebview/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1568 out of 2420 API elements (64.8 %) have documentation comments.

Some symbols that are missing documentation: multi_inappwebview, multi_inappwebview.ASN1DERDecoder, multi_inappwebview.ASN1DERDecoder.ASN1DERDecoder, multi_inappwebview.ASN1DERDecoder.decode, multi_inappwebview.ASN1DERDecoder.getContentLength.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:multi_inappwebview/multi_inappwebview.dart that imports:
  • package:multi_inappwebview/src/webview.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:multi_inappwebview/multi_inappwebview.dart that imports:
  • package:multi_inappwebview/src/webview.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:multi_inappwebview/multi_inappwebview.dart that imports:
  • package:multi_inappwebview/src/webview.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:multi_inappwebview/multi_inappwebview.dart that imports:
  • package:multi_inappwebview/src/webview.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

ERROR: Missing concrete implementations of 'getter WebView.implementation' and 'getter WebView.onDownloadStartRequest'.

lib/src/webview.dart:15:7

   ╷
15 │ class MultiInAppWebView extends StatefulWidget implements WebView {
   │       ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/webview.dart

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: MultiInAppWebView.progressWidget, MultiInAppWebView.loadingProgress, MultiInAppWebView.shouldOpenNewWindow, MultiInAppWebView.initialOptions

lib/src/webview.dart:15:7

   ╷
15 │ class MultiInAppWebView extends StatefulWidget implements WebView {
   │       ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/webview.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
event_bus ^2.0.0 2.0.0 2.0.0
flutter flutter 0.0.0 0.0.0
flutter_inappwebview ^5.3.2 5.8.0 6.0.0
fluttertoast ^8.0.8 8.2.6 8.2.6
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.3.2` on flutter_inappwebview does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions flutter_inappwebview to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
80
pub points
0%
popularity

Publisher

unverified uploader

multiple webview of flutter_inappwebview

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

event_bus, flutter, flutter_inappwebview, fluttertoast

More

Packages that depend on multi_inappwebview