multi_date_range_picker 0.0.5
multi_date_range_picker: ^0.0.5 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Add to your project a simple and customize Date range picker with multi range

8
likes
100 / 110
pub points
55 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:
Exceeded timeout of 0:20:00.000000
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
intl^0.16.00.16.10.17.0
meta^1.1.81.3.0-nullsafety.31.3.0
quiver^2.0.52.1.53.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
matcher-0.12.90.12.10
path-1.7.01.8.0
sky_engine-0.0.990.0.99
stack_trace-1.9.61.10.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.0` on intl does not support the stable version `0.17.0`, that was published 26 days ago.

When intl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions intl to update the constraint.

The constraint `^2.0.5` on quiver does not support the stable version `3.0.0`, that was published 12 days ago.

When quiver is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

8
likes
100
pub points
55%
popularity

Publisher

gungun974.com

Add to your project a simple and customize Date range picker with multi range

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

flutter, intl, meta, quiver

More

Packages that depend on multi_date_range_picker