mpris 1.0.0
mpris: ^1.0.0 copied to clipboard

A library to interface D-Bus MPRIS media players on linux systems.

1
likes
110/ 130
pub points
0%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 112 out of 156 API elements (71.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:mpris/mpris.dart that imports:
  • package:mpris/generated/mediaplayer2_player.dart that imports:
  • package:dbus/dbus.dart that imports:
  • package:dbus/src/dbus_server.dart that imports:
  • package:dbus/src/dbus_properties.dart that imports:
  • package:dbus/src/dbus_object_tree.dart that imports:
  • package:dbus/src/dbus_object.dart that imports:
  • package:dbus/src/dbus_client.dart that imports:
  • package:dbus/src/getuid.dart that imports:
  • dart:ffi
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dbus>=0.2.5 <0.3.00.2.50.6.6
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
collection-1.15.01.15.0
meta-1.7.01.7.0
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.2.5 <0.3.0` on dbus does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions dbus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

1
likes
110
pub points
0%
popularity

A library to interface D-Bus MPRIS media players on linux systems.

Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

dbus

More

Packages that depend on mpris