mp_audio_stream 0.1.5 copy "mp_audio_stream: ^0.1.5" to clipboard
mp_audio_stream: ^0.1.5 copied to clipboard

A simple multi-platform audio stream player for raw audio data streams.

5
likes
120/ 140
pub points
66%
popularity

We analyzed this package 8 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

10 out of 13 API elements (76.9 %) have documentation comments.

Some symbols that are missing documentation: audio_stream.AudioStreamStat.AudioStreamStat.empty, audio_stream.AudioStreamStat.exhaust, audio_stream.AudioStreamStat.full.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/mp_audio_stream_mastream.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
js ^0.6.4 0.6.7 0.7.1
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.4` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

5
likes
120
pub points
66%
popularity

Publisher

unverified uploader

A simple multi-platform audio stream player for raw audio data streams.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter, flutter_web_plugins, js, plugin_platform_interface

More

Packages that depend on mp_audio_stream