mono_kit 0.1.1+2

mono_kit #

A collection of convenient widgets and utils made by mono.


  • Make TextAnswerDialogResult to private


  • Change TextAnswerDialog's return type to Future


  • Increment version.


  • Add TextAnswerDialog.


  • Add reuseChild argument to BetterStreamBuilder/ValueObservableBuilder.


  • Add type parameter to FadePageRoute.


  • Change OverflowDetectableText's callback argument to double from bool in order to notify overflowed height.


  • Add BetterStreamBuilder


  • Port my private repository's source codes.


mono_kit_example #

Demonstrates how to use the mono_kit plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  mono_kit: ^0.1.1+2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mono_kit/mono_kit.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/utils/hud.dart.

Run flutter format to format lib/utils/hud.dart.

Format lib/widgets/itemized_text.dart.

Run flutter format to format lib/widgets/itemized_text.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flutter_cache_manager).


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
flutter_cache_manager ^0.3.2 0.3.2 1.1.0
rxdart ^0.22.0 0.22.0
url_launcher ^5.0.3 5.1.0
Transitive dependencies
async 2.3.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
http 0.12.0+2
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
path_provider 0.5.0+1 1.1.2
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
sqflite 1.1.6+2
string_scanner 1.0.4
synchronized 2.1.0+1
term_glyph 1.1.0
typed_data 1.1.6
uuid 2.0.2
vector_math 2.0.8
Dev dependencies