mono_kit 0.9.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 87

mono_kit #

A collection of convenient widgets and utils made by mono.

[0.9.5]

  • Change to PagingScrollController from PagingScroll Widget

[0.9.4]

  • Add PagingScroll

[0.9.3]

  • Add CenteredMaxWidth

[0.9.2]

  • Add pedantic_mono dependency

[0.9.1]

  • Add buildMode

[0.9.0]

  • Add LifeCycleObserver

[0.8.0]

  • Add UnfocusOnTap

[0.7.2]

  • Update dependencies

[0.7.1]

  • Update dependencies

[0.7.0]

  • Add ProgressMixin

[0.6.0]

  • Add Barrier Barrier.value named constructor which accepts bool.

[0.5.0]

[0.4.0]

[0.3.0]

[0.2.0]

  • Refactor RouteObserverProvider with provider and add its example.

[0.1.1+1]

  • Make TextAnswerDialogResult to private

[0.1.1]

  • Change TextAnswerDialog's return type to Future

[0.1.0]

  • Increment version.

[0.0.6]

  • Add TextAnswerDialog.

[0.0.5]

  • Add reuseChild argument to BetterStreamBuilder/ValueObservableBuilder.

[0.0.4]

  • Add type parameter to FadePageRoute.

[0.0.3]

  • Change OverflowDetectableText's callback argument to double from bool in order to notify overflowed height.

[0.0.2]

  • Add BetterStreamBuilder

[0.0.1]

  • Port my private repository's source codes.

example/README.md

mono_kit_example #

Demonstrates how to use the mono_kit plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mono_kit: ^0.9.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mono_kit/mono_kit.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
87
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/widgets/itemized_text.dart.

Run flutter format to format lib/widgets/itemized_text.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
disposable_provider ^1.1.0 1.1.0+2
flutter 0.0.0
flutter_cache_manager ^1.1.1 1.1.3
rxdart ^0.22.1 0.22.6
simple_logger ^1.5.1 1.5.1+1
subscription_holder ^1.0.0 1.0.0
url_launcher ^5.1.2 5.2.5
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.3
http 0.12.0+2
http_parser 3.1.3
logging 0.11.3+2
meta 1.1.7 1.1.8
path 1.6.4
path_provider 1.4.2
pedantic 1.8.0+1
platform 2.2.1
provider 3.1.0+1
sky_engine 0.0.99
source_span 1.5.5
sqflite 1.1.7+2
stack_trace 1.9.3
string_scanner 1.0.5
synchronized 2.1.0+1
term_glyph 1.1.0
typed_data 1.1.6
url_launcher_platform_interface 1.0.1
uuid 2.0.4
vector_math 2.0.8
Dev dependencies
flutter_test
pedantic_mono any