modern_charts 0.1.19

Dart js
Flutter web

A package for creating simple yet modern looking charts.

17
likes
80 / 110
pub points
80 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 38 out of 79 API elements (48.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:modern_charts/modern_charts.dart that imports:
  • package:modern_charts/src/utils.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Use `=` to separate a named parameter from its default value.

lib/src/datatable.dart:73:29

   ╷
73 │   List toList({bool growable: true}) => _cells.toList(growable: growable);
   │                             ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/datatable.dart

INFO: Avoid return types on setters.

lib/src/datatable.dart:157:3

    ╷
157 │   void set length(int value) {
    │   ^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/datatable.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
intl>=0.15.70.16.10.16.1
Transitive dependencies
PackageConstraintCompatibleLatest
path-1.7.01.7.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

17
likes
80
pub points
80%
popularity

A package for creating simple yet modern looking charts.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

jolleekin@gmail.com

License

BSD (LICENSE.md)

Dependencies

intl

More

Packages that depend on modern_charts