model_viewer 0.8.1 copy "model_viewer: ^0.8.1" to clipboard
model_viewer: ^0.8.1 copied to clipboard

A Flutter widget for rendering interactive 3D models in the glTF and GLB formats.

140
likes
30/ 140
pub points
79%
popularity

We analyzed this package 23 hours ago, and awarded it 30 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/drydart/model_viewer.dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.8.1 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.1. Cannot run `flutter pub outdated`.

pubspec.yaml:23:8

   ╷
23 │   sdk: '>=2.8.1 <3.0.0'
   │        ^^^^^^^^^^^^^^^^
   ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.1.

pubspec.yaml:23:8

   ╷
23 │   sdk: '>=2.8.1 <3.0.0'
   │        ^^^^^^^^^^^^^^^^
   ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.4.1)

pubspec.yaml:23:8

   ╷
23 │   sdk: '>=2.8.1 <3.0.0'
   │        ^^^^^^^^^^^^^^^^
   ╵

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

140
likes
30
pub points
79%
popularity

Publisher

verified publisherar.to

A Flutter widget for rendering interactive 3D models in the glTF and GLB formats.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

dogma, flutter, flutter_android, webview_flutter

More

Packages that depend on model_viewer