mod_http 1.1.1 icon indicating copy to clipboard operation
mod_http: ^1.1.1 copied to clipboard

A starting point for Dart libraries or applications.

0
likes
95/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 95 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:49

   ╷
13 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 245 out of 436 API elements (56.2 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:mod_http/mod_http.dart that imports:
  • package:mod_http/src/http.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 112 issues. Showing the first 2:

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/crypto.dart:79:25

   ╷
79 │     List<int> out = new List<int>(outputLen);
   │                         ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/crypto.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/crypto.dart:123:18

    ╷
123 │       return new List<int>(0);
    │                  ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/crypto.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
getstream>=1.2.0 <2.0.01.2.11.2.1
meta>=1.2.3 <2.0.01.9.01.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Dart 2.19.0.

0
likes
95
pub points
0%
popularity

Publisher

unverified uploader

A starting point for Dart libraries or applications.

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

getstream, meta

More

Packages that depend on mod_http