mobx_provider 0.0.4
mobx_provider: ^0.0.4 copied to clipboard

package for binding the UI with your stores (viewmodels) easily , the package is inspired by filled stacks archticture pattern

13
likes
90/ 130
pub points
47%
popularity

We analyzed this package 29 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 50 API elements (30.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/example/counter_store.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/mobx_providers/mobx_widget_provider.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_mobx^1.1.0+11.1.0+22.0.2
mobx^1.2.1+11.2.1+42.0.5
provider^4.3.14.3.36.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
nested-1.0.01.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.1.0+1` on flutter_mobx does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_mobx to update the constraint.

The constraint `^1.2.1+1` on mobx does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions mobx to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

13
likes
90
pub points
47%
popularity

package for binding the UI with your stores (viewmodels) easily , the package is inspired by filled stacks archticture pattern

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_mobx, mobx, provider

More

Packages that depend on mobx_provider