mno_fsm 0.2.3 copy "mno_fsm: ^0.2.3" to clipboard
mno_fsm: ^0.2.3 copied to clipboard

A library for finite state machine realization in Dart. Inspired by Tinder StateMachine for Kotlin.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add mno_fsm

With Flutter:

 $ flutter pub add mno_fsm

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  mno_fsm: ^0.2.3

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:mno_fsm/mno_fsm.dart';
0
likes
130
pub points
73%
popularity

Publisher

verified publishermantano.com

A library for finite state machine realization in Dart. Inspired by Tinder StateMachine for Kotlin.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

More

Packages that depend on mno_fsm