mirrorme2 0.1.0
mirrorme2: ^0.1.0 copied to clipboard

A mirrors helper library; adjusted for Dart 2 by Ross Albertson

0
likes
75 / 110
pub points
5 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 30 API elements (40.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:mirrorme2/mirrorme2.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 29 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/helpers/annotation_checker.dart:4:3

  ╷
4 │ ┌   /**
5 │ │    * Check if the Annotation [T] is on the annotated object [obj]
6 │ └    */
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/helpers/annotation_checker.dart

INFO: Prefer using /// for doc comments.

lib/helpers/annotation_checker.dart:11:4

   ╷
11 │ ┌    /**
12 │ │     * Get the Instance of the Annotation [T] from the annotated object [obj]
13 │ └     */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/helpers/annotation_checker.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
75
pub points
5%
popularity

A mirrors helper library; adjusted for Dart 2 by Ross Albertson

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ozonesurfer68@gmail.com

License

Apache 2.0 (LICENSE)

More

Packages that depend on mirrorme2