min_id 1.1.0 copy "min_id: ^1.1.0" to clipboard
min_id: ^1.1.0 copied to clipboard

ID generator for dart easily like eat 🥮🥮🥮🥮. You can generate unique string, unique number, unique any thing by min_id 👍.

9
likes
140/ 160
pub points
68%
popularity

We analyzed this package 34 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 45 API elements (42.2 %) have documentation comments.

Some symbols that are missing documentation: min_id, min_id.BaseFormatter, min_id.BaseFormatter.BaseFormatter, min_id.GenerateMode, min_id.GenerateMode.GenerateMode.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

WARNING: Dead code.

lib/string_formatter/string_formatter.dart:66:11

   ╷
66 │           break;
   │           ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/string_formatter/string_formatter.dart

WARNING: Dead code.

lib/string_formatter/string_formatter.dart:70:11

   ╷
70 │           break;
   │           ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/string_formatter/string_formatter.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

9
likes
140
pub points
68%
popularity

Publisher

verified publisheruit.social

ID generator for dart easily like eat 🥮🥮🥮🥮. You can generate unique string, unique number, unique any thing by min_id 👍.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

BSD-3-Clause (LICENSE)

More

Packages that depend on min_id