migrate_to_1 0.0.1+1

  • Readme
  • Changelog
  • Installing
  • new46

MigrateTo1 #

A tool for migrating a dependent package to support 1.0.0 in an ecosystem friendly manner.

This is designed to work with the dart_lsc tool to perform ecosystem-wide migrations.

0.0.1+1 #

  • Rename main.dart to work with pub global run.

0.0.1 #

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  migrate_to_1: ^0.0.1+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:migrate_to_1/executable.dart';
import 'package:migrate_to_1/migrate_base.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 26, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Fix bin/migrate_to_1.dart. (-0.50 points)

Analysis of bin/migrate_to_1.dart reported 1 hint:

line 5 col 13: This function has a return type of 'Future

Fix lib/src/migrate_to_1.dart. (-0.50 points)

Analysis of lib/src/migrate_to_1.dart reported 1 hint:

line 2 col 8: Unused import: 'dart:io'.

Format lib/executable.dart.

Run dartfmt to format lib/executable.dart.

Format lib/migrate_base.dart.

Run dartfmt to format lib/migrate_base.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and migrate_to_1.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
args ^1.5.3 1.6.0
file ^5.1.0 5.1.0
pub_semver ^1.4.3 1.4.4
pubspec_parse ^0.1.5 0.1.5
Transitive dependencies
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.12
intl 0.16.1
json_annotation 3.0.1
meta 1.1.8
path 1.6.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
yaml 2.2.0
Dev dependencies
pedantic ^1.8.0
test ^1.6.0