mfm 1.0.7+1 copy "mfm: ^1.0.7+1" to clipboard
mfm: ^1.0.7+1 copied to clipboard

A MFM (Misskey Flavored Markup language) Renderer for Flutter.

1
likes
130/ 140
pub points
69%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

54 out of 70 API elements (77.1 %) have documentation comments.

Some symbols that are missing documentation: mfm, mfm.Mfm, mfm.Mfm.defaultBorderColor, mfm.Mfm.isUseAnimation, mfm.MfmBlurScope.inBlurScope.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: 'textScaleFactor' is deprecated and shouldn't be used. Use textScaler instead. Use of textScaleFactor was deprecated in preparation for the upcoming nonlinear text scaling support. This feature was deprecated after v3.12.0-2.0.pre.

lib/src/mfm_element_widget.dart:42:7

   ╷
42 │       textScaleFactor: 1,
   │       ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mfm_element_widget.dart

INFO: 'textScaleFactor' is deprecated and shouldn't be used. Use textScaler instead. Use of textScaleFactor was deprecated in preparation for the upcoming nonlinear text scaling support. This feature was deprecated after v3.12.0-2.0.pre.

lib/src/mfm_inline_span.dart:16:7

   ╷
16 │       textScaleFactor: 1,
   │       ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mfm_inline_span.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
colorfilter_generator ^0.0.8 0.0.8 0.0.8
dotted_border ^2.1.0 2.1.0 2.1.0
flutter flutter 0.0.0 0.0.0
mfm_parser ^1.0.3 1.0.5 1.0.5
vector_math ^2.1.4 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
matrix2d - 1.0.4 1.0.4
meta - 1.11.0 1.14.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
sky_engine - 0.0.99 0.0.99

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.