meteorify 1.0.7
meteorify: ^1.0.7 copied to clipboard

A dart package to interact with Meteor. Connect your web or flutter apps, written in Dart, with the Meteor framework.

6
likes
90/ 130
pub points
43%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/meteorify_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 39 out of 48 API elements (81.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:meteorify/meteorify.dart that imports:
  • package:meteorify/src/meteor/subscribed_collection.dart that imports:
  • package:ddp/ddp.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ddp^0.0.130.0.130.0.13
mongo_dart^0.4.00.4.40.7.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
basic_utils-2.7.13.7.0
bson-0.3.41.0.3
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
json_annotation-3.1.14.3.0
logging-0.11.41.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mongo_dart_query-0.4.21.0.2
more-2.8.03.3.0
path-1.8.01.8.0
pointycastle-2.0.13.3.4
pool-1.5.01.5.0
quiver-2.1.53.0.1+1
rational-0.3.81.2.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on mongo_dart does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions mongo_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

6
likes
90
pub points
43%
popularity

Publisher

shivamarora.dev

A dart package to interact with Meteor. Connect your web or flutter apps, written in Dart, with the Meteor framework.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

ddp, mongo_dart

More

Packages that depend on meteorify