meedu 9.1.0 copy "meedu: ^9.1.0" to clipboard
meedu: ^9.1.0 copied to clipboard

A simple State Managment, Dependency Injection, Reactive programming for dart Projects.

28
likes
140/ 160
pub points
54%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

69 out of 166 API elements (41.6 %) have documentation comments.

Some symbols that are missing documentation: base_notifier, base_notifier.BaseNotifier.dispose, base_notifier.ListeneableNotifier, base_notifier.ListeneableNotifier.clearListeners, base_notifier.ListeneableNotifier.setDisposableCallback.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The referenced identifier is a wildcard.

lib/rx/rx_notifier.dart:34:34

   ╷
34 │     return subject.stream.listen(_);
   │                                  ^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/rx/rx_notifier.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
meta ^1.9.0 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

28
likes
140
pub points
54%
popularity

Publisher

verified publishermeedu.app

A simple State Managment, Dependency Injection, Reactive programming for dart Projects.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

meta

More

Packages that depend on meedu