measure 0.1.0
measure: ^0.1.0 copied to clipboard

Library for working with measurements, quantities and units.

1
likes
120/ 130
pub points
42%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 496 out of 611 API elements (81.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.01.15.01.15.0
intl^0.17.00.17.00.17.0
petitparser^4.2.04.3.04.3.0
quiver^3.0.13.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
clock-1.1.01.1.0
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.20.0, Dart 2.14.0.

1
likes
120
pub points
42%
popularity

Publisher

appsup.be

Library for working with measurements, quantities and units.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

collection, intl, petitparser, quiver

More

Packages that depend on measure