meadow 0.1.2

meadow #

A selection of easy to use form field widgets to be used within Flutter forms:

  • Row of Buttons
  • Date Picker
  • Drop Down List
  • Row of Radio Buttons
  • Switch
  • Checkbox

Getting Started #

For help getting started with Flutter, view the online documentation.

For help on editing package code, view the documentation.

Example #

There is an example that demonstrates an example use of each form field widget in the example project

[0.0.1] - 08 October 2018:

  • Initial Release

[0.0.2] - 08 October 2018:

  • Documentation Updates

[0.1.0] - 08 October 2018:

  • Added example project

[0.1.1] - 08 October 2018:

  • Moved example project to one file


Meadow Example Project #

This is an example project that uses all meadow form fields in a flutter form

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  meadow: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:meadow/meadow.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Format lib/form_field_button_row.dart.

Run flutter format to format lib/form_field_button_row.dart.

Format lib/form_field_checkbox.dart.

Run flutter format to format lib/form_field_checkbox.dart.

Format lib/form_field_date_picker.dart.

Run flutter format to format lib/form_field_date_picker.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/form_field_drop_down.dart (Run flutter format to format lib/form_field_drop_down.dart.)
  • lib/form_field_radio_buttons.dart (Run flutter format to format lib/form_field_radio_buttons.dart.)
  • lib/form_field_switch.dart (Run flutter format to format lib/form_field_switch.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

Package is getting outdated. (-21.10 points)

The package was last published 63 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
intl ^0.15.7 0.15.8 0.16.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8