mcg_simple_web_widget 0.0.2

Flutter Android iOS web

A new Flutter package.

0
likes
70 / 110
pub points
9 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 84 out of 224 API elements (37.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: AkilliSatir.widgetlar, AkilliSatir.genisEkranParcaSayisi, AkilliSatir.normalEkranParcaSayisi, AkilliSatir.kucukEkranParcaSayisi, AkilliSatir.widgetlarArasiBosluk, AkilliSatir.ilkWidgetGenis, AkilliSatir.sonWidgetGenis

lib/akillirow.dart:3:7

  ╷
3 │ class AkilliSatir extends StatelessWidget {
  │       ^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/akillirow.dart

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: Bolum.kaydirmaKontrolu

lib/bolum.dart:4:7

  ╷
4 │ class Bolum extends StatelessWidget {
  │       ^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/bolum.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animated_background^1.0.51.0.51.0.5
animated_text_kit^2.0.02.2.02.2.0
auto_animated^2.0.12.1.02.1.0
auto_animated_icon^1.1.41.1.41.1.4
flutterflutter0.0.00.0.0
flutter_page_indicator^0.0.30.0.30.0.3
flutter_swiper^1.1.61.1.61.1.6
mcg_extension^0.0.30.0.30.0.3
parallax_image^0.3.1+10.3.1+10.3.1+1
responsive_builder^0.1.40.1.90.3.0
scroll_to_index^1.0.51.0.61.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
transformer_page_view-0.1.60.1.6
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
visibility_detector-0.1.50.1.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.4` on responsive_builder does not support the latest published version `0.3.0`

pubspec.yaml:15:23

   ╷
15 │   responsive_builder: ^0.1.4
   │                       ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs