maybe 0.4.0
maybe: ^0.4.0 copied to clipboard

An helper for ensuring that values are checked before they are used.

0
likes
105 / 130
pub points
55 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 105 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 34 API elements (73.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

0
likes
105
pub points
55%
popularity

An helper for ensuring that values are checked before they are used.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on maybe