This is the Dart version of angular/material2 being ported by individual.
You may be looking for the official Material Design components for AngularDart?
Synced with the 2.0.0-alpha.9 except gesture support and non 'available' components.
This is the e2e example app which includes all of the components and core functions usages.
Add this to your package's pubspec.yaml file. (The example)
Import this library as
import 'package:material2_dart:material.dart'. (The example)
Your contribution is welcome. Please note that this project is nothing more than a porting work of angular/material2.
Many tests have not been ported, so it is much appreciated if you help to port them.
I would not add any original features on it. If you need some new features, please consider contributing angular/material2.
If you find this Dart version's specific bugs, please file them at the issue tracker.
pub run test --pub-serve=8080 -p dartium
Fix several regressions on 0.4.3.
Renderer to support Angular2 2.1.0 or higher.
Relax dependent package's constraint.
Upgrade angular2 dep to ^2.0.0.
Bundle pre compiled css and source map files so that users don't need to compile this package's sass files in transformer phase.
The e2e example has moved to the independent repository (https://github.com/ntaoo/material2_dart_e2e_example) to be more practical working example without relative path package dependencies.
Sync with the alpha.9 only for "Available" components.
(breaking): Changed the package layout to follow the convention.
import 'package:material2_dart/material.dart'; to import the all components and core functions.
Sync with the alpha.8 only for "Available" components.
MdAnchor disabled didn't work.
All porting works have done for the current target (anuglar/material2 6/15/2016).
scissorsagain in order to fix many build errors.
scissorspackage which requires
sasspackage for easier setup.
Add this to your package's pubspec.yaml file:
dependencies: material2_dart: ^0.4.4
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.4.4||Dec 22, 2016|
|0.4.3||Dec 14, 2016|
|0.4.2||Nov 7, 2016|
|0.4.1||Nov 3, 2016|
|0.4.0||Oct 20, 2016|
|0.3.0||Sep 28, 2016|
|0.2.0||Sep 28, 2016|
|0.1.1||Sep 13, 2016|
|0.1.0||Jun 25, 2016|
|0.0.11||Jun 23, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.19.1 <2.0.0|