match_generator 0.4.1 icon indicating copy to clipboard operation
match_generator: ^0.4.1 copied to clipboard

Generator for match extension methods

1
likes
90/ 140
pub points
58%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 20 API elements (5.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:match_generator/match_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:match_generator/match_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:match_generator/match_generator.dart that imports:
  • package:match_generator/match_enum_generator.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/macro.dart that imports:
  • package:analyzer/src/summary2/kernel_compilation_service.dart that imports:
  • package:_fe_analyzer_shared/src/macros/compiler/request_channel.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'element' is deprecated and shouldn't be used. Use element2 instead.

lib/match_class_generator.dart:8:40

  ╷
8 │           e.allSupertypes.map((i) => i.element).contains(c))
  │                                        ^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/match_class_generator.dart

INFO: 'isEnum' is deprecated and shouldn't be used. Use `is EnumElement` instead.

lib/match_generator.dart:20:19

   ╷
20 │       if (element.isEnum) {
   │                   ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/match_generator.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^4.2.04.7.05.4.0
build^2.0.02.3.12.3.1
match^0.4.10.4.10.4.1
source_gen^1.2.21.2.61.2.7
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-47.0.052.0.0
args-2.3.22.3.2
async-2.10.02.10.0
collection-1.17.11.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-2.2.42.2.4
file-6.1.46.1.4
glob-2.1.12.1.1
logging-1.1.11.1.1
meta-1.9.01.9.0
package_config-2.1.02.1.0
path-1.8.31.8.3
pub_semver-2.1.32.1.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.2.0` on analyzer does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.

1
likes
90
pub points
58%
popularity

Publisher

verified publisher iconbech.io

Generator for match extension methods

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

analyzer, build, match, source_gen

More

Packages that depend on match_generator