mastodon 0.1.0

Mastodon #

A simple API for accessing Mastodon instances.

Usage #

A simple usage example:

import 'package:mastodon/mastodon.dart';

main() {
  // Using mastodon.cloud instance by default.
  var m = new Mastodon.usingAccessToken('an OAuth access token for this instance');
  for (Account a in m.findAccounts('myk*')) {
    print(a);
  }
}

See mastodon_test.dart for more examples.

Features and bugs #

Incomplete and not well tested, so it is full of them.

Fix them at https://github.com/mykdavies/Mastodon!

Todo #

  • Rate limiting mechanism not implemented.

Changelog #

0.1.0 #

  • Massive tidy-up with (nearly) every lint rule turned on.

0.0.5, 0.0.4 #

  • dartdocs is a harsh code critic :-(.

0.0.3 #

  • Improved error handling, better testing. Some more documentation.

0.0.2 #

  • Updated to allow dartdocs to parse.

0.0.1 #

  • Initial version, created by Stagehand

example/mastodon_example.dart

// Copyright (c) 2017, mike. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:mastodon/mastodon.dart';

main() {
  final Mastodon m = new Mastodon();
  print(m.getInstance());
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mastodon: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mastodon/mastodon.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0