masamune_signin_facebook 0.8.5+4
masamune_signin_facebook: ^0.8.5+4 copied to clipboard

Plugin for signing in with a Facebook account.

0
likes
110/ 130
pub points
44%
popularity

We analyzed this package 26 hours ago, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 4 API elements (100.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:masamune_signin_facebook/masamune_signin_facebook.dart that imports:
  • package:masamune/masamune.dart that imports:
  • package:masamune/media/mobile/mobile.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_auth^3.1.33.3.03.3.0
firebase_core^1.7.01.10.21.10.2
flutterflutter0.0.00.0.0
flutter_facebook_auth^3.5.63.5.6+33.5.6+3
masamune^0.8.00.8.5+1070.8.5+107
masamune_firebase^0.8.00.8.5+150.8.5+15
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
async-2.8.12.8.2
boolean_selector-2.1.02.1.0
bordered_text-2.0.02.0.0
cached_network_image-3.2.03.2.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
cloud_firestore-2.5.43.1.1
cloud_firestore_platform_interface-5.4.65.4.6
cloud_firestore_web-2.6.12.6.1
cloud_functions-3.2.03.2.0
cloud_functions_platform_interface-5.0.155.0.15
cloud_functions_web-4.2.14.2.1
collapsible-1.0.01.0.0
collection-1.15.01.15.0
connectivity-3.0.63.0.6
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
csslib-0.17.10.17.1
csv-5.0.15.0.1
datetime_picker_formfield-2.0.02.0.0
device_info-2.0.32.0.3
device_info_platform_interface-2.0.12.0.1
dio-4.0.44.0.4
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_auth_platform_interface-6.1.56.1.5
firebase_auth_web-3.3.13.3.1
firebase_core_platform_interface-4.2.04.2.0
firebase_core_web-1.4.01.4.0
firebase_dynamic_links-3.0.23.0.2
firebase_model_notifier-0.8.5+490.8.5+49
firebase_storage-10.2.010.2.0
firebase_storage_platform_interface-4.0.74.0.7
firebase_storage_web-3.2.13.2.1
flutter_blurhash-0.6.00.6.0
flutter_breadcrumb-1.0.11.0.1
flutter_cache_manager-3.3.03.3.0
flutter_facebook_auth_platform_interface-2.7.02.7.0
flutter_facebook_auth_web-2.6.0+22.6.0+2
flutter_hooks-0.18.10.18.1
flutter_markdown-0.6.80.6.8
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_riverpod-1.0.0-dev.71.0.1
flutter_sequence_animation-4.0.0-nullsafety4.0.0-nullsafety
flutter_web_plugins-0.0.00.0.0
font_awesome_flutter-9.2.09.2.0
freezed_annotation-0.14.31.0.0
geoflutterfire-3.0.13.0.1
hooks_riverpod-1.0.0-dev.71.0.1
html-0.15.00.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image_picker-0.8.4+40.8.4+4
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.4.04.4.0
katana-0.8.5+180.8.5+18
katana_firebase-0.8.5+120.8.5+12
katana_module-0.8.5+590.8.5+59
katana_module_builder_annotation-1.0.11.0.1
katana_routing-0.8.5+500.8.5+50
loading_animations-2.2.02.2.0
logger-1.1.01.1.0
markdown-4.0.14.0.1
matcher-0.12.100.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
model_notifier-0.8.5+490.8.5+49
octo_image-1.0.11.0.1
package_info_plus-1.3.01.3.0
package_info_plus_linux-1.0.31.0.3
package_info_plus_macos-1.3.01.3.0
package_info_plus_platform_interface-1.0.21.0.2
package_info_plus_web-1.0.41.0.4
package_info_plus_windows-1.0.41.0.4
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
responsive_grid-2.0.02.0.0
riverpod-1.0.0-dev.71.0.1
rxdart-0.27.30.27.3
selectable_autolink_text-2.3.02.3.0
share-2.0.42.0.4
shared_preferences-2.0.92.0.9
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
simple_gesture_detector-0.2.00.2.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sprintf-6.0.06.0.0
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
state_notifier-0.7.10.7.1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.8
typed_data-1.3.01.3.0
url_launcher-6.0.176.0.17
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
url_strategy-0.2.00.2.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
video_player-2.2.72.2.7
video_player_platform_interface-4.2.04.2.0
video_player_web-2.0.42.0.4
win32-2.3.12.3.1
wordpress_api-1.2.01.2.0
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.