flutter_device_locale 0.4.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 95

Build Status pub package License: MIT Flutter.io


A Flutter plugin for retrieving the device locale information.

Installation #

Add this to your package's pubspec.yaml file:

dependencies:
  flutter_device_locale: <latest version>

Install packages from the command line (or from your editor):

flutter pub get

Import flutter_device_locale:

import 'package:flutter_device_locale/flutter_device_locale.dart';

Usage #

Retrieve the current locale:

Locale locale = await DeviceLocale.getCurrentLocale();

Retrieve the preferred locales:

List<Locale> preferredLocales = await DeviceLocale.getPreferredLocales();

Issues #

Please file any issues, bugs or feature request here.

License #

This project is licensed under the MIT License

Author #

This Flutter plugin is developed by Florin Bratan. You can contact me at florin@leadcode.dev

0.1.0 #

  • Implemented the Android method call

0.2.0 #

  • Implemented the iOS method call

0.3.0 #

  • getPreferredLocales() now returns a List

0.3.1 #

  • Fixed possible exception with the NonNull annotation (Android)

0.3.2 #

  • Updated license, readme, links

0.3.3 #

  • Fixed an issue regarding the Android package naming

0.4.0 #

  • Added support for Flutter Web

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:flutter_device_locale/flutter_device_locale.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _deviceLocale = 'Not loaded';
  String _preferredLocales = 'Not loaded';

  @override
  void initState() {
    super.initState();
    initDeviceLocale();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initDeviceLocale() async {
    String deviceLocale = 'Unknown';
    String preferredLocales = 'Unknown';
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      deviceLocale = (await DeviceLocale.getCurrentLocale()).toString();
      preferredLocales = (await DeviceLocale.getPreferredLocales()).join(", ");
    } on PlatformException {
      deviceLocale = 'Failed to get the device locale.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _deviceLocale = deviceLocale;
      _preferredLocales = preferredLocales;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text(
              'Current Locale: $_deviceLocale\n\nPreferred Locales: $_preferredLocales'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_device_locale: ^0.4.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_device_locale/flutter_device_locale.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
90
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
95
Learn more about scoring.

We analyzed this package on Apr 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

5 out of 5 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_web_plugins 0.0.0
plugin_platform_interface ^1.0.1 1.0.2
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8