mark_with_label 0.0.7

Dart Marker With Labels #

This project is a library to use MarkerWithLabel for V3 from dart scripts.

See Google Maps for Dart

Usage #

To use this library in your code:

  • add a dependency in your pubspec.yaml :

      google_maps: ">=3.0.0 <4.0.0"
      marker_with_labels: ">0.0.1 <1.0.0"
  • add import in your dart code:

    import 'package:google_maps/google_maps.dart';
    import 'package:marker_with_label/marker_with_label.dart';
  • Include the Maps API JavaScript using a script tag before your dart script and after Google Maps API.

    <script src=""></script>
    <script src="<your_js_location>/markerwithlabel.js"></script>

A very simple example :

import 'dart:html';

import 'package:google_maps/google_maps.dart';

void main() {
  final mapOptions = new MapOptions()
    ..zoom = 8 = new LatLng(-34.397, 150.644);
  new GMap(document.getElementById("map-canvas"), mapOptions);
  var markerWithLabelOptions = new MarkerWithLabelOptions()
    ..labelContent = "Hello Label" = gMap
    ..position = latLng;
  new MarkerWithLabel(markerWithLabelOptions);

Examples #

Examples found at in the example directory.

License #

Apache 2.0

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

0.0.2 #

  • Fix package name, remove dart from name

0.0.3 #

  • Fix example dependency import

0.0.4 #

  • Add icon property on marker options

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  mark_with_label: ^0.0.7

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:mark_with_label/marker_with_label.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0