maps_adapter_google_maps 0.2.2
maps_adapter_google_maps: ^0.2.2 copied to clipboard

Flutter iOS

An adapter between 'package:maps' and 'google_maps_flutter'.

1
likes
80 / 110
pub points
32 %
popularity

We analyzed this package on Jan 22, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 5 API elements (80.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:maps_adapter_google_maps/maps_adapter_google_maps.dart that imports:
  • package:maps_adapter_google_maps/src/google_maps.dart that imports:
  • package:maps_adapter_google_maps/src/google_maps_impl_default.dart that imports:
  • package:maps/maps.dart that imports:
  • package:maps/src/adapters/apple_maps.dart that imports:
  • package:maps/src/adapters/apple_maps_impl_default.dart that imports:
  • package:apple_maps_flutter/apple_maps_flutter.dart that declares support for platforms: iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
google_maps_flutter^1.0.101.1.11.1.1
maps^0.4.10.4.30.4.3
Transitive dependencies
PackageConstraintCompatibleLatest
apple_maps_flutter-0.1.30.1.3
async-2.4.22.5.0-nullsafety.3
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
cryptography-1.4.11.4.1
cryptography_flutter-1.0.01.0.0
csslib-0.16.20.16.2
cupertino_icons-1.0.21.0.2
database-0.3.30.3.3
fixnum-0.10.110.10.11
flutter_plugin_android_lifecycle-1.0.111.0.11
google_maps_flutter_platform_interface-1.1.01.1.0
html-0.14.0+40.14.0+4
js-0.6.3-nullsafety.30.6.3-nullsafety.3
matcher-0.12.90.12.10-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
mime-0.9.70.9.7
path-1.7.01.8.0-nullsafety.3
plugin_platform_interface-1.0.31.0.3
protobuf-1.1.01.1.0
quiver-2.1.52.1.5
share-0.6.5+40.6.5+4
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
stream_transform-1.2.01.2.0
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
universal_html-1.2.41.2.4
universal_io-1.0.21.0.2
url_launcher-5.7.105.7.10
url_launcher_linux-0.0.1+40.0.1+4
url_launcher_macos-0.0.1+90.0.1+9
url_launcher_platform_interface-1.0.91.0.9
url_launcher_web-0.1.5+10.1.5+1
url_launcher_windows-0.0.1+30.0.1+3
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
web_browser-0.4.00.4.0
web_node-0.1.20.1.2
webview_flutter-1.0.71.0.7
zone_local-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
80
pub points
32%
popularity

An adapter between 'package:maps' and 'google_maps_flutter'.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

terrier989@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter, google_maps_flutter, maps

More

Packages that depend on maps_adapter_google_maps