maps 0.5.0
maps: ^0.5.0 copied to clipboard

A cross-platform geographic maps package. Supports Apple MapKit, Bing Maps, and Google Maps. Works in all platforms supported by Flutter, including browsers.

23
likes
80 / 130
pub points
74 %
popularity

We analyzed this package on Jun 17, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 99 out of 137 API elements (72.3 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:maps/maps.dart that imports:
  • package:maps/src/adapters/apple_maps.dart that imports:
  • package:maps/src/adapters/apple_maps_impl_default.dart that imports:
  • package:apple_maps_flutter/apple_maps_flutter.dart that declares support for platforms: iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
apple_maps_flutter0.1.30.1.31.0.0
collection^1.15.01.15.01.15.0
cryptography^2.0.02.0.12.0.1
flutterflutter0.0.00.0.0
js^0.6.30.6.30.6.3
kind^0.5.00.5.20.5.2
meta^1.3.01.3.01.4.0
url_launcher^6.0.26.0.66.0.6
web_browser^0.5.00.5.00.5.0
web_node^0.2.00.2.10.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
crypto-3.0.13.0.1
csp-0.1.10.1.1
csslib-0.17.00.17.0
cupertino_icons-1.0.31.0.3
fixnum-1.0.01.0.0
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
mime-1.0.01.0.0
path-1.8.01.8.0
plugin_platform_interface-2.0.02.0.0
protobuf-2.0.02.0.0
share-2.0.42.0.4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_html-2.0.82.0.8
universal_io-2.0.42.0.4
url_launcher_linux-2.0.02.0.0
url_launcher_macos-2.0.02.0.0
url_launcher_platform_interface-2.0.32.0.3
url_launcher_web-2.0.12.0.1
url_launcher_windows-2.0.02.0.0
vector_math-2.1.02.1.0
webview_flutter-2.0.82.0.8

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `0.1.3` on apple_maps_flutter does not support the stable version `0.1.4`.

Try running dart pub upgrade --major-versions apple_maps_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.9.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

23
likes
80
pub points
74%
popularity

Publisher

dint.dev

A cross-platform geographic maps package. Supports Apple MapKit, Bing Maps, and Google Maps. Works in all platforms supported by Flutter, including browsers.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

apple_maps_flutter, collection, cryptography, flutter, js, kind, meta, url_launcher, web_browser, web_node

More

Packages that depend on maps