mapper 0.2.3 copy "mapper: ^0.2.3" to clipboard
mapper: ^0.2.3 copied to clipboard

Library converts map to object and object to map. Can use external converters for custom complex types.

1
likes
130/ 140
pub points
49%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

7 out of 14 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: mapper, mapper.Entity.fullMatch, mapper.Parser.decode, mapper.Parser.encode, mapper.Property.ignore.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:mapper/mapper.dart that imports:
  • package:mapper/src/instance.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:mapper/mapper.dart that imports:
  • package:mapper/src/instance.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:mapper/mapper.dart that imports:
  • package:mapper/src/instance.dart that imports:
  • dart:mirrors
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/src/decoder.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/encoder.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

1
likes
130
pub points
49%
popularity

Publisher

unverified uploader

Library converts map to object and object to map. Can use external converters for custom complex types.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

More

Packages that depend on mapper