map_polyline_draw 1.0.2

Flutter Android iOS

Map Polyline Draw Package to show Map Polyline between Two Points

Map Polyline Draw #

Map Polyline Draw Package show Map Polyline between Two Points in the map. It also has the feature to change the marker icon with your icon just provide the assets location. It also has feature to change polyline width and color. Map Polyine Draw using google_maps_flutter package for Google map and http package to get data from Google Map API

Screen Shots #

alt text alt text

Usage #

  • To use this, add map_polyline_draw as a dependency in your pubspec.yaml file.

Getting Started #

Simple Code Snippet #


  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        backgroundColor: Colors.black,
        title: Text(
          widget.title,
        ),
      ),
      body: MapPolyLineDraw(
        apiKey: "YOUR_API_KEY",
        firstPoint: MapPoint(24.8960309, 67.0792159),
        secondPoint: MapPoint(24.9425822, 67.0691675),
      ),
    );
  }
  • apiKey: "YOUR_API_KEY"
  • firstPoint: MapPoint(latitude, longitude)
  • secondPoint: MapPoint(latitude, longitude)

These three are compulsory to add otherwise it will generate an error

1
likes
100
pub points
51%
popularity

Map Polyline Draw Package to show Map Polyline between Two Points

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

safwanidrees957@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, google_maps_flutter, http

More

Packages that depend on map_polyline_draw