mango_vin 1.0.0

  • Readme
  • Changelog
  • Installing
  • new58

vin #

Vehicle Database and VIN Decoder

Run with Docker #

  • $ docker build -t avosa/vin:dev .
  • $ docker rm VINDEV
  • $ docker run -d -p 8095:8095 --network mango_net -v db/:/db/ --name VINDEV avosa/vin:dev
  • $ docker logs VINDEV

API #

GET v1/lookup/WAUZZZ8E88A025765

Mango-VIN #

1.0.0 #

  • Initial Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mango_vin: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mango_vin/lookupapi.dart';
import 'package:mango_vin/vinapi.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because:

  • package:mango_vin/lookupapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on ios

Because:

  • package:mango_vin/lookupapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on linux

Because:

  • package:mango_vin/lookupapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on macos

Because:

  • package:mango_vin/lookupapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on windows

Because:

  • package:mango_vin/lookupapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime native

Because:

  • package:mango_vin/lookupapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime native-aot

Because:

  • package:mango_vin/lookupapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Health issues and suggestions

Document public APIs. (-1 points)

6 out of 6 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/lookupapi.dart. (-1.49 points)

Analysis of lib/lookupapi.dart reported 3 hints:

line 5 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 12 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 19 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mango_vin.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 < 3.0.0
mango_ui ^1.0.2 1.0.3