mango_ui 1.0.3

  • Readme
  • Changelog
  • Installing
  • 71

mango-ui #

Shared Dart libraries to be used in conjunction with the Mango Go "framework"

Mango-ui #

1.0.3 #

  • removed duplicate Bearer Header.

1.0.2 #

  • changed getEndpoint to return String

1.0.1 #

  • Added getEndpoints to decode endpoints stored by the claims
  • Added getToken to get token stored by the claims

1.0.0 #

  • The overall architecture has changed, and many functions are no longer required
  • Services now host their own API.dart files

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mango_ui: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mango_ui/formstate.dart';
import 'package:mango_ui/keys.dart';
import 'package:mango_ui/requester.dart';
import 'package:mango_ui/trustvalidator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Jul 1, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Analysis suggestions

Package not compatible with runtime flutter-native of android

Because of the import of dart:html via the import chain package:mango_ui/formstate.dart->dart:html

Package not compatible with runtime flutter-native of ios

Because of the import of dart:html via the import chain package:mango_ui/formstate.dart->dart:html

Package not compatible with runtime flutter-native of linux

Because of the import of dart:html via the import chain package:mango_ui/formstate.dart->dart:html

Package not compatible with runtime flutter-native of macos

Because of the import of dart:html via the import chain package:mango_ui/formstate.dart->dart:html

Package not compatible with runtime flutter-native of windows

Because of the import of dart:html via the import chain package:mango_ui/formstate.dart->dart:html

Package not compatible with runtime native-aot

Because of the import of dart:html via the import chain package:mango_ui/formstate.dart->dart:html

Package not compatible with runtime native-jit

Because of the import of dart:html via the import chain package:mango_ui/formstate.dart->dart:html

Health suggestions

Fix lib/requester.dart. (-2.48 points)

Analysis of lib/requester.dart reported 5 hints:

line 25 col 1: Prefer using /// for doc comments.

line 29 col 19: Unnecessary new keyword.

line 36 col 7: Use isNotEmpty instead of length

line 55 col 19: Unnecessary new keyword.

line 62 col 7: Use isNotEmpty instead of length

Fix lib/keys.dart. (-1.49 points)

Analysis of lib/keys.dart reported 3 hints:

line 9 col 12: Unnecessary new keyword.

line 21 col 10: Unnecessary new keyword.

line 34 col 13: Unnecessary new keyword.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mango_ui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 < 3.0.0