Mango API: Vehicle
Vehicle is where you get the full information of a car.
Run with Docker #
- $ docker build -t avosa/vehicle:dev .
- $ docker rm VehicleDEV
- $ docker run -d -p 8098:8098 --network mango_net --name VehicleDEV avosa/vehicle:dev
- $ docker logs VehicleDEV
- Updated Year to String.
- Initial Release
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: mango_vehicle: ^1.0.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
import 'package:mango_vehicle/lookupapi.dart'; import 'package:mango_vehicle/vehicleapi.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.8.4
- pana: 0.13.15
Health issues and suggestions
lib/vehicleapi.dart. (-68.36 points)
lib/vehicleapi.dart failed with 4 errors:
line 5 col 8: Target of URI doesn't exist: '../pathlookup.dart'.
line 6 col 8: Target of URI doesn't exist: 'requester.dart'.
line 9 col 21: The function 'buildPath' isn't defined.
line 29 col 10: The function 'invokeService' isn't defined.
Document public APIs. (-1 points)
8 out of 8 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
lib/lookupapi.dart. (-1.99 points)
lib/lookupapi.dart reported 4 hints:
line 5 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 12 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 19 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
line 26 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
Maintenance issues and suggestions
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
mango_vehicle.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.0.0 < 3.0.0|